[m-rev.] for review: test_helper_N

Julien Fischer jfischer at opturion.com
Fri Jun 16 14:38:14 AEST 2023



On Fri, 16 Jun 2023, Zoltan Somogyi wrote:

> Months ago we agreed on the concept that all test modules
> that are not the main modules of their test cases should have
> "helper" in their names, with a numeral suffix. This does that
> for the hard_coded directory.
>
> This is for review of the general appoach; the details are mostly very boring.

...

> Rename X's aux modules as X_helper_N in hard_coded.
> 
> tests/hard_coded/*.m:
>     Rename modules as mentioned above.
>
>     In a few cases, where the main module's name itself had a suffix,
>     such as "_mod_a" or "_main", remove that suffix. This entails
>     renaming the .exp file as well. (In some cases, this meant that
>     the name of a helper module was "taken over" by the main module
>     of the test case.)
>
>     Update all references to the moved modules.
>
>     General updates to programming style, such as
>
>     - replacing DCG notation with state var notation
>     - replacing (C->T;E) with (if C then T else E)

That presumably excludes any tests that are intended to specifically test DCG
notation or (C->T;E) syntax?

>     - moving pred/func declarations to just before their code
>     - replacing io.write/io.nl sequences with io.write_line
>     - replacing io.print/io.nl sequences with io.print_line
>     - fixing too-long lines
>     - fixing grammar errors in comments
> 
> tests/hard_coded/Mmakefile:
> tests/hard_coded/Mercury.options:
>     Update all references to the moved modules.
>
>     Enable the constant_prop_int test case. The fact that it wasn't enabled
>     before is probably an accident. (When constant_prop_int.m was created,
>     the test case was added to a list in the Mmakefile, but that list
>     was later removed due to never being referenced.)
> 
> tests/hard_coded/constant_prop_int.{m,exp}:
>     Delete the calls to shift operations with negative shift amounts,
>     since we have added a compile-time error for these since the test
>     was originally created.

That's fine.

Julien.


More information about the reviews mailing list